Ask Your Question

how do I disable the window showing the logs of the power flow solution in python?

asked 2013-03-11 02:45:00 -0500

anonymous user


I have been trying to use python script to solve power flow problem using the pss/e module. When I finished the solving, I got windows showing the log of the solution, including the Siemens company introduction and the power flow result. Since I just need the results for post-processing, I find these windows very disturbing. Can somebody kindly tell me how to disable these windows?

edit retag flag offensive close merge delete


Were the windows pop ups? In that case you can use the `redirect` module. `import redirect; redirect.psse2py()`

JervisW gravatar imageJervisW ( 2013-03-15 20:00:18 -0500 )edit

Thanks. It works!

Taichi gravatar imageTaichi ( 2013-04-01 01:42:23 -0500 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2013-03-11 09:05:21 -0500

cajief gravatar image

PSS/E prints it's output to different "devices" depending on the activity: progress, prompt, and report. The progress output is the one producing the messages you're referring to. To change how the program interacts with these devices there are some API commands.

ierr = progress_output(islct, filarg, options)
ierr = prompt_output(islct, filarg, options)
ierr = report_output(islct, filarg, options)

You can disable these output devices by setting ISLCT=6. However, it's good practice is to save these log files in case something goes awry or for future analysis (i.e. ISLCT=2 & filarg=output file name).

Having the output go to the PSS/E GUI can slow things down when there's a lot of text being printed. Check out the API documentation for more details.

edit flag offensive delete link more



There is also the alert device: ierr = alert_output(islct, filarg, options)

jsexauer gravatar imagejsexauer ( 2013-03-11 11:03:46 -0500 )edit

answered 2020-06-01 10:13:29 -0500

NunoFul gravatar image

I also have a problem with the production of these reports, even directing them to file (islct = 2). After many simulations (about 4000 or 5000), instead of around 0.001 seconds, these commands start taking 40+ seconds each!

The workaround was simply deactivate them. Since I am running dynamic simulations in an iterative optimisation algorithm, only the best solutions have reports. The others are ignored.

Anyways, if anyone has any suggestion on this, I would appreciate it :) Thanks.

Best, Nuno

edit flag offensive delete link more


In a the dynamic run, to keep the log file open but minimum logging, use:,0,0,0,0) This way, to can catch warning or error messages from the dynamic models.

jconto gravatar imagejconto ( 2020-06-01 11:18:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools


Asked: 2013-03-11 02:45:00 -0500

Seen: 1,139 times

Last updated: Jun 01