Ask Your Question
0

Error with importing pssexplore34 (related to _set_psse_loc)

asked 2019-06-05 14:43:21 -0500

bikiran1991 gravatar image

updated 2019-06-05 14:45:27 -0500

Hi,

I am trying to run psspy in psse xplore v34 using the following block of script:

import os
import sys

PSSE_PY27 = r'C:\Program Files (x86)\PTI\PSSEXplore34\PSSPY27'
PSSBIN = r'C:\Program Files (x86)\PTI\PSSEXplore34\PSSBIN'
sys.path.append(PSSBIN)
sys.path.append(PSSE_PY27)
os_path_PSSE=r'C:\Program Files (x86)\PTI\PSSEXplore34\PSSBIN'
os.environ['PATH'] += ';' + os_path_PSSE

import pssexplore34

However, there is the following error message:

Error in opening PSSE PSSE Xplore 34 registry key 'Product Paths'
Traceback:
File '.\psseloc.py', line 140, in _set_psse_loc
WindowsError: [Error 2] The system cannot find the file specified

Can someone help me with this? Is there some other path that I need to provide?

edit retag flag offensive close merge delete

Comments

Same error happened to me a few days ago using the licensed version instead of the explore one. Try to comment out line import pssexplore34. That worked in my case.

toderesa97 gravatar imagetoderesa97 ( 2019-06-07 13:54:36 -0500 )edit

Have you checked that those are working directories?

toderesa97 gravatar imagetoderesa97 ( 2019-06-07 14:03:58 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-06-12 17:40:33 -0500

bikiran1991 gravatar image

Figured it out. This was due to a python path conflict. I had two separate python installations (one using http://python.org and another using anaconda), and both these installations were on system path. Once i removed the anaconda one from the path, i could run psspy using the vanilla python.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2019-06-05 14:43:21 -0500

Seen: 267 times

Last updated: Jun 12