Ask Your Question
0

PSSE 33.12 dyntools pssplotc issue

asked 2018-09-11 11:50:28 -0500

oppossumX gravatar image

Has anyone tried using dyntools in PSSE 33.12? I am getting the following import error when using the CHNF and OUTDATA classes.

    outobj = dyntools.OUTDATA(thefile, 1, None)
  File ".\dyntools.py", line 231, in __init__
  File ".\dyntools.py", line 286, in _get_data_fortran
ImportError: No module named pssplotc

I can see the pssplotc.pyd file in the PSSPY27 and PSSPY34 folders of my PSSE 34 install but can't find it anywhere in my PSSE 33 install folder. I am using the same scripts and files that worked with PSSE 33.11 when running in PSSE 33.12.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2018-09-11 17:42:00 -0500

jconto gravatar image

Scripts for v.33.11 cannot be used for v.33.12 when using dyntools. Now the optional variable 'outvrsn' has to be named in the calling function:

MyOUTVRSN = 0
# OK call for v.33.11:
chnfobj = dyntools.CHNF(outfile,MyOUTVRSN)
#OK call for v.33.12:
chnfobj = dyntools.CHNF(outfile,outvrsn=MyOUTVRSN)
edit flag offensive delete link more

Comments

Thanks, this worked.

oppossumX gravatar imageoppossumX ( 2018-09-11 20:09:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2018-09-11 11:50:28 -0500

Seen: 94 times

Last updated: Sep 11