Ask Your Question
0

PSSE 34 excelpy missing; Github downloads not working

asked 2018-07-21 18:04:24 -0500

dimc18 gravatar image

Hi everyone,

Super new to PSSE. Starting it for a GMD research project this summer! I am trying to use the GIC module, and when attempting to make an Excel template for the .gic file, I get the error 'excelpy' not found.

I've looked on the internet and here's what I've done:

According to another post, "How to install modules in PSSEXplore34", PSSE 34 has all files for Excel export/import except this excelpy. (of course)

I also found the post, "PSSE 34 with excel", where it was advised to try in the PSSE command line import PSSE34 import pssexcel, but this did not work.

I have tried to download just the excelpy file from GitHub users, but this calls other functions, so I tried downloading their whole folder, but it gets messy and PSSE is picky about where all the files are downloaded so I stopped that after hours of trial and error.

And now I'm here! All I need is to make this .gic file template! There is not a lot of information out there about using the GIC module anyway. I found one that might help with creating a template, but depending on the PSSE version, it could not work with 34.

Does anyone have the excelpy file and would be willing to share it or have any other solution? Thank you for anything, really!

  • Chris
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-07-26 19:57:01 -0500

dimc18 gravatar image

Hi guys!

First off, thank you jconto for your reply and help, but the file will not be needed :]

I feel a little awkward and embarrassed sharing this answer, but it should be known that there is a solution! It turns out the installation file my friend sent me was missing the excelpy file...somehow??

In short, I had to reinstall PSSE, but it wasn't just that! I had to uninstall and reinstall PSSE, winpy, pycharm, and python, 4 times before I got everything right and all the files were included! I don't know why this happened...I'm careful when installing programs, but for some reason certain files just weren't there.

Anyway, for anyone else who was missing this file, it seems uninstalling everything then reinstalling fixed my problem. I guess I just had to try it multiple times before asking on a forum ^^

Hope this helps somebody else

edit flag offensive delete link more
0

answered 2018-07-25 22:06:48 -0500

jconto gravatar image

where to send the file to?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Stats

Asked: 2018-07-21 18:04:24 -0500

Seen: 69 times

Last updated: Jul 26