Can I create xyplots in Python 2.7 for *.out files created using PSSE 32

asked 2013-08-01 22:31:11 -0600

Yagna gravatar image

When I attempt to do this, I am getting empty plots. (I have checked for the proper scales). I want to make sure if this issue is due to PSSE version or something wrong with the code.

edit retag flag offensive close merge delete


You need to use Python 2.5, the error should say something about "Bad Magic Number".

JervisW gravatar imageJervisW ( 2013-08-04 18:12:32 -0600 )edit

Python 2.7 should work fine if you are using PSSE 33, but reading out files created by PSSE 32. Your issue seems like you have forgotten to close the figures after plotting?

sheng gravatar imagesheng ( 2013-08-05 00:29:21 -0600 )edit

@JervisW Yes, I looked through the questions archive and found the use of pssepath module. It solved the magicnumber issue and now I can switch between 2.5 and 2.7 (v32 and v33) seamlessly.

Yagna gravatar imageYagna ( 2013-08-05 11:54:31 -0600 )edit

Do you have any demo code? Perhaps like sheng mentions there is something missing?

JervisW gravatar imageJervisW ( 2013-08-05 21:34:24 -0600 )edit

@JervisW It turns out that the generator that I tried to the plot the rotor angle plot is turned off in the case. I tried a different plot and it works no issues. I would like if you would help me with the other question on the CON data retrieval and storage. I am kinda stuck on my script.

Yagna gravatar imageYagna ( 2013-08-05 21:49:23 -0600 )edit